Skip to main content
Las versiones 5.x de PHP siguen siendo las más usadas para el desarrollo web, pero quedarán sin soporte a final de año.

DOS DE CADA TRES WEBS SE MUESTRAN CON VERSIONES 5.X DE PHP

DOS DE CADA TRES WEBS SE MUESTRAN CON VERSIONES 5.X DE PHP

Iniciamos este post de una manera un tanto técnica. ¿Qué es PHP y por qué este porcentaje tan alto?

PHP es un lenguaje de programación para el uso de aplicaciones web con HTML y tiene el soporte de los CMS más usados como por ejemplo WordPress, Drupal, Joomla o Prestashop. Según W3Techs, el 61.4% de páginas web aún se basan en las versiones 5.x. Estas versiones dejarán de recibir soporte y actualizaciones de seguridad para sus servidores este mismo año.

Esto significa que podrían exponerse a hackers, robo de información o malware. Por eso, la mejor opción es actualizar a la versión 7.2. Es más rápida y segura y seguirá recibiendo soporte hasta el 30 de noviembre de 2020.

No se trata de un tema nuevo y es conocido desde hace tiempo. Sin embargo, los desarrolladores de PHP muestran una aparente calma y siguen basando webs en PHP 5.6 en nuevos desarrollos.

La versión PHP 5.6 se convirtió en la versión de PHP más usada en internet durante la primavera de 2017. Versión que estaba programada para dejar de recibir actualizaciones a finales de 2017, pero los desarrolladores de PHP vieron que dejar de ofrecer soporte cuando era la versión más usada sería un desastre.

PRIMEROS EFECTOS

PRIMEROS EFECTOS

En el ámbito de los CMS, Drupal es el único que empieza a exigir PHP 7 como requisito mínimo. WordPress y Joomla, dos de los CMS más usados, parece que darán el paso en breve.

WordPress sigue exigiendo la versión 5.2 y Joomla, la 5.3. Esto puede resultar en un grave problema en el futuro ya que todas las webs desarrolladas con estos CMS podrían tener brechas de seguridad en un futuro cercano.

Cabe mencionar que PHP no ha sufrido ninguna brecha de seguridad grave en los últimos años. Es por eso que sigue siendo un lenguaje fiable y las cifras hablan por si solas. Sin embargo, esto podría cambiar muy pronto. Solo es necesario que se encuentre una brecha de seguridad para que todas las webs con esas versiones peligren.

RAZONES PARA ACTUALIZAR A PHP 7.2

RAZONES PARA ACTUALIZAR A PHP 7.2

Ya sabemos que, a partir del 2019, las versiones a partir de PHP 7 van a ser las únicas que recibirán soporte. Pero esa no es la única razón por la que deberíamos actualizar. La velocidad y el uso de memoria fue una gran mejora con PHP 7 y sigue mejorando con cada versión.

La velocidad aumenta hasta un 150%, algo que para el usuario final es una gran mejora. Además, tener una web rápida también mejora tu SEO. La última versión permite al sistema ejecutar el doble de solicitudes por segundo.

Los tres puntos que toda web debe cumplir son: confidencialidad, integridad y disponibilidad. Sin esos tres puntos, los datos de tu web pueden ser vulnerables. Con versiones anteriores a PHP 7, las webs dejan de poseer los tres puntos clave.

Si tu web recibe un ataque, la información de tus usuarios o de tu empresa queda expuesta. Además también podrías comunicar mala imagen de empresa, perder clientes o incluso causar pérdidas económicas considerables.

También es importante considerar que según el nuevo reglamento de RGPD, si decides no actualizar a la nueva versión más segura de PHP, en un posible ataque, te haces responsable de esa pérdida de información. Cosa que puede llegar a multas de alto coste.

Hemos enumerado los efectos de la obsolescencia de PHP 5.x. No dudes en actualizar tu entorno web a la última versión para evitar los problemas de seguridad derivados que tu empresa pueda acabar teniendo en la red.

Hasta la próxima... week week

Hasta la próxima… week week

Les versions 5.x de PHP segueixen sent les més usades per al desenvolupament web, però quedaran sense suport a final d’any.

Dos de cada tres webs es mostren amb versions 5.x de PHP

Iniciem aquest post d’una manera una miqueta tècnica. Què és PHP i perquè aquest percentatge tan alt?

PHP és un llenguatge de programació per a l’ús d’aplicacions web amb HTML i té el suport dels CMS més usats com per exemple WordPress, Drupal, Joomla o Prestashop. Segons W3Techs, el 61.4% de pàgines web encara es basen en les versions 5.x de PHP. Aquestes versions de PHP deixaran de rebre suport i actualitzacions de seguretat per als seus servidors aquest mateix any.

Això significa que podrien exposar-se a hackers, robatori d’informació o malware. Per això, la millor opció és actualitzar a la versió 7.2, més ràpida i segura i que seguirà rebent suport fins al 30 de novembre de 2020.

No es tracta d’un tema nou i és conegut des de fa temps. No obstant això, els desenvolupadors de PHP mostren una aparent calma i segueixen basant els seus webs en PHP 5.6 en nous desenvolupaments.

La versió PHP 5.6 es va convertir en la versió de PHP més usada en internet durant la primavera de 2017. Versió que estava programada per deixar de rebre actualitzacions a la fi de 2017, però els desenvolupadors de PHP van veure que deixar d’oferir suport quan era la versió més usada seria un desastre.

Primers efectes

En l’àmbit dels CMS, Drupal és l’únic que comença a exigir PHP 7 com a requisit mínim. WordPress i Joomla, dos dels CMS més usats, sembla que faran el pas en breu.

WordPress segueix exigint la versió 5.2 i Joomla, la 5.3. Això pot resultar en un greu problema en el futur ja que totes les webs desenvolupades amb aquests CMS podrien tenir bretxes de seguretat en un futur proper.

Cal esmentar que PHP no ha sofert cap bretxa de seguretat greu en els últims anys, i per això segueix sent un llenguatge fiable i les xifres parlen per si soles. No obstant, això podria canviar molt ràpid. Solament és necessari que un hacker trobi una bretxa de seguretat perquè totes les webs basades en aquestes versions quedin en perill.

Raons per actualitzar a PHP 7.2

Ja sabem que, a partir del 2019, les versions a partir de PHP 7 seran les úniques que rebran suport, però aquesta no és l’única raó per la qual hauríem d’actualitzar. La velocitat i l’ús de memòria va ser una gran millora amb PHP 7 i segueix millorant amb cada versió.

La velocitat augmenta fins a un 150%, cosa que per a l’usuari final és una gran millora. A més, tenir una web ràpida també millora el teu SEO. L’última versió permet al sistema executar el doble de sol·licituds per segon.

Els tres punts que tota web ha de complir són: confidencialitat, integritat i disponibilitat. Sense aquests tres punts, les dades del teu web poden resultar ser vulnerables, i amb versions anteriors a PHP 7, les webs deixen de posseir els tres punts clau.

Si el teu web rep un atac, la informació dels teus usuaris o de la teva empresa queda exposada. A més també podries comunicar una mala imatge d’empresa, perdre clients o fins i tot causar pèrdues econòmiques considerables.

També és important considerar que segons el nou reglament de RGPD, si decideixes no actualitzar a la nova versió més segura de PHP, en un possible atac, et fas responsable d’aquesta pèrdua d’informació. Cosa que pot arribar a multes d’alt cost.

Hem enumerat els efectes de l’obsolescència de PHP 5.x. No dubtis a actualitzar el teu entorn web a l’última versió per evitar els problemes de seguretat derivats que la teva empresa pugui acabar tenint a la xarxa.

Fins a la propera... week week

Nolasc Azcona

Author Nolasc Azcona

More posts by Nolasc Azcona

Leave a Reply

diecisiete − doce =

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Addmira todos los derechos reservados.